TDA1543 problem

TDA1543 problem

PostPostao/la grunf » 02 ožu 2012, 11:13

Forumaši :D

Jučer sam pomagao prijatelju složiti DAC s CS8416 i 10 kom TDA1543 po ovoj shemi

http://www.pavouk.org/hw/spdifdac/en_index.html

slika

i imamo nekakv čudan problem, sam CS8416 radi OK,testirano 100% i kad se spoji na TDA1543 više ne radi,jednostavno poludi i ne šalje više nikakv signal prema TDA1543

meni je sumnjiv napon na pinovima 1,2,3 od TDA1543 koji iznosi oko 2,6V,po papirima ti pinovi 'mogu primiti najveći napon od 2V i to digitalni signal

tda1543.gif
tda1543.gif (3.78 KiB) Pogledano 1920 put/a.


e sad ako netko ima DAC ili player s TDA1543 da mi izmjeri napone na tim nožicam,znači kad 'radi' i kad nema digitalnog signala na njemu

ne vjerujem da su TDA1543 lažni,dosad nisam naišao na te probleme
"Bolje nešto od nečega nego ništa od ničega."
Avatar
grunf
 
Postovi: 844
Pridružen/a: 05 ruj 2011, 22:51
Lokacija: Šibenik

Re: TDA1543 problem

PostPostao/la arlekin » 02 ožu 2012, 11:37

Dobar dan, dobri ljudi!

Evo, da se predstavim. Moje ime je Andrija i ja sam čovjek iza neuspjeha ovog daca. :mrgreen:
Ništa, da skratim. Pokušavam lemiti uz Grunfove smjernice, pa sam se odlučio za ovaj projekt sa TDA1543 da malo nešto naučim i poboljšam zvuk koji slušam.

Prvi post pa odmah pomoć. Malo je bezobrazno, ali nemojte mi zamjeriti.
arlekin
 
Postovi: 13
Pridružen/a: 02 ožu 2012, 11:27

Re: TDA1543 problem

PostPostao/la tom_hifi » 02 ožu 2012, 11:41

Dva citata s linka projekta:

Conclusion

My DAC has problems to work. First I thought that SPDIF signal is too low. I tried to bridge pulse transformer. Next I thought that SPDIF source from computer is bad. I checked that something is generated and I tried SPDIF output from set-top-box. I tried optical input too, but everything without success. It looks like that on the I2S output is nothing generated. There should be idle mute sample signal. It looks like there are some problem with reset of circuit CS8416. I tried to reset him manually many times and I reached only that he somehow works and on output was generated nice loud noise which was muted in a pause. I tried to replace reset circuit with special 3 pin reset IO MCP120, but without success. I tried to place small resistors on signal paths between decoder and DAC (some people do this for lower interference) but still without success. Next I tried to replace SMD capacitors in PLL filter with types with recommended dielectric and nothing happen. Finally i replaced circuit CS8416 for another, but situation is same. I can not tell where I made mistake. Wiring diagram is relative simple. Circuit is used in another DACs on the internet and there works.


Update

I fixed the problem. CM CHEANG give me a notice, that main problem is, that IO TDA1543 is not identical to TDA1543A. I couldn't find datasheet anywhere on the internet. TDA1543 use I2S data format input, but TDA1543A use EIAJ format, which I identified like "Right justified". If you use these circuits, you must switch the output data format of CS8416 with two resistors R3 to +5V and R7 to GND like in datasheet. After this DAC begins to play very nicely. After two hours there was cracking in a sound. DACs are really hot and some of them probably dies when they was running without a cooler. Don't run DACs on 8V voltage without cooler!


;)
Avatar
tom_hifi
 
Postovi: 2087
Pridružen/a: 16 kol 2011, 16:33
Lokacija: Oroslavje

Re: TDA1543 problem

PostPostao/la grunf » 02 ožu 2012, 11:42

tom_hifi je napisao/la:Dva citata s linka projekta:

Conclusion

My DAC has problems to work. First I thought that SPDIF signal is too low. I tried to bridge pulse transformer. Next I thought that SPDIF source from computer is bad. I checked that something is generated and I tried SPDIF output from set-top-box. I tried optical input too, but everything without success. It looks like that on the I2S output is nothing generated. There should be idle mute sample signal. It looks like there are some problem with reset of circuit CS8416. I tried to reset him manually many times and I reached only that he somehow works and on output was generated nice loud noise which was muted in a pause. I tried to replace reset circuit with special 3 pin reset IO MCP120, but without success. I tried to place small resistors on signal paths between decoder and DAC (some people do this for lower interference) but still without success. Next I tried to replace SMD capacitors in PLL filter with types with recommended dielectric and nothing happen. Finally i replaced circuit CS8416 for another, but situation is same. I can not tell where I made mistake. Wiring diagram is relative simple. Circuit is used in another DACs on the internet and there works.


Update



I fixed the problem. CM CHEANG give me a notice, that main problem is, that IO TDA1543 is not identical to TDA1543A. I couldn't find datasheet anywhere on the internet. TDA1543 use I2S data format input, but TDA1543A use EIAJ format, which I identified like "Right justified". If you use these circuits, you must switch the output data format of CS8416 with two resistors R3 to +5V and R7 to GND like in datasheet. After this DAC begins to play very nicely. After two hours there was cracking in a sound. DACs are really hot and some of them probably dies when they was running without a cooler. Don't run DACs on 8V voltage without cooler!


;)


savladali smo to odavno :D ,ovo je ko neka dječja bolest,blizu si riješenja a nikako do njega :lol: :lol:
"Bolje nešto od nečega nego ništa od ničega."
Avatar
grunf
 
Postovi: 844
Pridružen/a: 05 ruj 2011, 22:51
Lokacija: Šibenik

Re: TDA1543 problem

PostPostao/la tom_hifi » 02 ožu 2012, 11:59

Možda onda najbolje da stavite finalnu vašu shemu, pa će se lakše pronaći greška.
Avatar
tom_hifi
 
Postovi: 2087
Pridružen/a: 16 kol 2011, 16:33
Lokacija: Oroslavje

Re: TDA1543 problem

PostPostao/la grunf » 02 ožu 2012, 12:03

tom_hifi je napisao/la:Možda onda najbolje da stavite finalnu vašu shemu, pa će se lakše pronaći greška.



shema ti je gori stavljena
"Bolje nešto od nečega nego ništa od ničega."
Avatar
grunf
 
Postovi: 844
Pridružen/a: 05 ruj 2011, 22:51
Lokacija: Šibenik

Re: TDA1543 problem

PostPostao/la sstrsat » 02 ožu 2012, 12:03

Grunfe, ajmo po redu. Prvo, jesi li sa skopom proviril da li na izlazima iz CSA8416 (pinovi 26, 27 i 28) imas data i clock signale amplitude otprilike napona napajanja (ako je sve ka na shemi sa Vl od 5V tribal bis imat TTL nivoe) kad je CS8416 odvojen od svih TDA1543 (znaci sam za sebe). Ako to imas, ne tribas se obazirat na sadrzaj signala na ta 3 pina, CS u tom slucaju sigurno radi kako triba.

Ako to imas dok je CS odvojen a spajanjem sa TDA1543 neka od te 3 linije (ili sve) padne na nulu ili se digne na high ili uocis da je doslo do kakve deformacije signala, onda je ili CS preopterecen tolikim brojem paralelnih DAC chipova ili je neki od TDA1543 chipova krepal pa radi monade. Ne bi smilo bit nikakve vidljive razlike izmedju opterecenog i neopterecenog CS-a, eventualno pad amplitude signala za koji mici postotak i nista vise.
Ako je ovo prvo da ga toliko paralelnih TDA1543 preopterecuje onda ces morat ugradit buffer (ne cijevni :lol: ) izmedju CS i TDA a ako je u pitanju to da je neki TDA krepal onda ih moras vadit jednog po jednogdok ne napipas koji je krepal. Valjda si stavil podnozja za njih jer ako nisi morat ces rezat linije dok ne napipas krepanoga :lol:

A buffer je i inace jako pozeljno stavit izmedju CS-a i tolikog broja paralelno vezanih potrosaca. Ako zbog niceg drugog onda zato da neminovni kapaciteti spojnih veza medju tolikim potrosacima budu njime odvojeni od samog CS-a

Napon koji sad miris na ulaznim pinovima TDA ti ne triba bit nikakav pokazatelj, njih CS triba vuc gori ili doli. Mozes ih provat (kad je CS odvojen) sa pull up / pull down otpornikom od par K povuc gori i doli i odma vidit da li to slusaju
Krepat ma ne molat
Avatar
sstrsat
 
Postovi: 1745
Pridružen/a: 04 svi 2011, 17:21
Lokacija: Rijeka

Re: TDA1543 problem

PostPostao/la grunf » 02 ožu 2012, 12:08

sstrsat je napisao/la:Grunfe, ajmo po redu. Prvo, jesi li sa skopom proviril da li na izlazima iz CSA8416 (pinovi 26, 27 i 28) imas data i clock signale amplitude otprilike napona napajanja (ako je sve ka na shemi sa Vl od 5V tribal bis imat TTL nivoe) kad je CS8416 odvojen od svih TDA1543 (znaci sam za sebe). Ako to imas, ne tribas se obazirat na sadrzaj signala na ta 3 pina, CS u tom slucaju sigurno radi kako triba.


ovo gori sve odrađeno i sve OK

sstrsat je napisao/la:Ako to imas dok je CS odvojen a spajanjem sa TDA1543 neka od te 3 linije (ili sve) padne na nulu ili se digne na high ili uocis da je doslo do kakve deformacije signala, onda je ili CS preopterecen tolikim brojem paralelnih DAC chipova ili je neki od TDA1543 chipova krepal pa radi monade. Ne bi smilo bit nikakve vidljive razlike izmedju opterecenog i neopterecenog CS-a, eventualno pad amplitude signala za koji mici postotak i nista vise.
Ako je ovo prvo da ga toliko paralelnih TDA1543 preopterecuje onda ces morat ugradit buffer (ne cijevni :lol: ) izmedju CS i TDA a ako je u pitanju to da je neki TDA krepal onda ih moras vadit jednog po jednogdok ne napipas koji je krepal. Valjda si stavil podnozja za njih jer ako nisi morat ces rezat linije dok ne napipas krepanoga :lol:

A buffer je i inace jako pozeljno stavit izmedju CS-a i tolikog broja paralelno vezanih potrosaca. Ako zbog niceg drugog onda zato da neminovni kapaciteti spojnih veza medju tolikim potrosacima budu njime odvojeni od samog CS-a

Napon koji sad miris na ulaznim pinovima TDA ti ne triba bit nikakav pokazatelj, njih CS triba vuc gori ili doli. Mozes ih provat (kad je CS odvojen) sa pull up / pull down otpornikom od par K povuc gori i doli i odma vidit da li to slusaju


moja je sumnja da je neki TDA1543 krepa ili ovo šta ti kažeš da CS ne može goniti ovoliko TDA1543
"Bolje nešto od nečega nego ništa od ničega."
Avatar
grunf
 
Postovi: 844
Pridružen/a: 05 ruj 2011, 22:51
Lokacija: Šibenik

Re: TDA1543 problem

PostPostao/la sstrsat » 02 ožu 2012, 12:11

grunf je napisao/la:moja je sumnja da je neki TDA1543 krepa ili ovo šta ti kažeš da CS ne može goniti ovoliko TDA1543


Ako imas podnozja ispod TDA onda je to dijagnostika od dvi minute ali ako nimas onda cakiju u ruke i rezi folije :lol: . Ali nemoj u tom slucaju pocet rezat od prvoga nego od sredine tako da odma ustanovis na kojoj strani je problem.
Ovo ca san te prvo pital jesi li proviril skopom same izlaze iz CS-a, kako stojimo sa time?
Krepat ma ne molat
Avatar
sstrsat
 
Postovi: 1745
Pridružen/a: 04 svi 2011, 17:21
Lokacija: Rijeka

Re: TDA1543 problem

PostPostao/la ilimzn » 02 ožu 2012, 12:13

Ocigledno rijesenje bi bilo stavljati jedan po jedan TDA... ali nekako imam osjecaj da ste ih sve odjednom zalemili :P
ilimzn
Iron Man
 
Postovi: 979
Pridružen/a: 05 svi 2011, 12:39

Sljedeća

Natrag na Digitalni izvori zvuka

Na mreži

Trenutno korisnika/ca: / i 1 gost.